import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "[A-HJ-NP-TV-Z]{2}[\\s-]{0,1}[0-9]{3}[\\s-]{0,1}[A-HJ-NP-TV-Z]{2}|[0-9]{2,4}[\\s-]{0,1}[A-Z]{1,3}[\\s-]{0,1}[0-9]{2}";
final String string = "## OLD FROMAT (complete) ##\n"
+ "3123 AA 11\n"
+ "3123-AA-11\n"
+ "3123AA11\n"
+ "8987 VG 33\n"
+ "8987VG33\n\n"
+ "## OLD FORMAT (with few characters) ##\n"
+ "31 F 11\n\n"
+ "## NEW FORMAT ##\n"
+ "AA 123 BB\n"
+ "AA-222-BB\n"
+ "DD345EE\n\n"
+ "AO 123 BB // O is excluded\n"
+ "AI-123-BB // I is excluded\n"
+ "AU123BB // U is exclided\n"
+ "AZ 123 BI\n"
+ "AZ-123-BU\n"
+ "AZ123BO";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}