# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"[A-HJ-NP-TV-Z]{2}[\s-]{0,1}[0-9]{3}[\s-]{0,1}[A-HJ-NP-TV-Z]{2}|[0-9]{2,4}[\s-]{0,1}[A-Z]{1,3}[\s-]{0,1}[0-9]{2}"
test_str = ("## OLD FROMAT (complete) ##\n"
"3123 AA 11\n"
"3123-AA-11\n"
"3123AA11\n"
"8987 VG 33\n"
"8987VG33\n\n"
"## OLD FORMAT (with few characters) ##\n"
"31 F 11\n\n"
"## NEW FORMAT ##\n"
"AA 123 BB\n"
"AA-222-BB\n"
"DD345EE\n\n"
"AO 123 BB // O is excluded\n"
"AI-123-BB // I is excluded\n"
"AU123BB // U is exclided\n"
"AZ 123 BI\n"
"AZ-123-BU\n"
"AZ123BO")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.