# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(?<='.*)\bday(?=s\b|\b)/night/gm;t' <<< "'*** This day is the day of all days
'*** This day is the day of all days
Dim day as integer 'so far so good today but maybe not another day
day=day+1 'a daystar is a planet visible in the east before sunrise
Regex is not perfect
text1.Text = \"'day\" ' we don't want to change that one
"