#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)(?<='.*)\bday(?=s\b|\b)"
Local $sString = "'*** This day is the day of all days" & @CRLF & _
" '*** This day is the day of all days" & @CRLF & _
" Dim day as integer 'so far so good today but maybe not another day" & @CRLF & _
" day=day+1 'a daystar is a planet visible in the east before sunrise" & @CRLF & _
"" & @CRLF & _
"Regex is not perfect" & @CRLF & _
"text1.Text = "'day" ' we don't want to change that one" & @CRLF & _
""
Local $sSubst = "night"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)