using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<='.*)\bday(?=s\b|\b)";
string substitution = @"night";
string input = @"'*** This day is the day of all days
'*** This day is the day of all days
Dim day as integer 'so far so good today but maybe not another day
day=day+1 'a daystar is a planet visible in the east before sunrise
Regex is not perfect
text1.Text = ""'day"" ' we don't want to change that one
";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}