re = /(?<='.*)\bday(?=s\b|\b)/m
str = '\'*** This day is the day of all days
\'*** This day is the day of all days
Dim day as integer \'so far so good today but maybe not another day
day=day+1 \'a daystar is a planet visible in the east before sunrise
Regex is not perfect
text1.Text = "\'day" \' we don\'t want to change that one
'
subst = 'night'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result