use strict;
my $str = 'Joel Dorfman
David C. Thomas
George Stager III
Jerome Jay Allen
Shaunda Richardson-Snell
Shelley J. O\'Brien
Anthony Stiel, Jr.
James Van Harn II
L. Marcinkowski
S.M. Rutkowski
S. M. Rutkowski
E. Todd Brown
Marc A. ORourke
James CW Roberts III
Holly A. McClellan
Thomas-Robert Peterson
Annette DeLaHuerta
Wm. Craig Faulk
JD Haughey
Adam de Angeli
Keith den Hollander';
my $regex = qr/^((?:[ \-]?[A-Z][a-z]+|[A-Z][a-z]?\.?)+)(?: ?[A-Z]\.?)* ([A-Za-z]{,3}(?:[ \-]?[A-Z]'?[A-Z]?[a-z]+\.?,?)+[A-Z \-.]*)$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}