$re = '/(?<!\d)(1(?>(?1))*2)(?!\d)/m';
$str = '111222222 112222 1111222
111222 1122 12 112222';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);