re = /(?<!\d)(1(?>(?1))*2)(?!\d)/m
str = '111222222 112222 1111222
111222 1122 12 112222'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end