#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?sm)(?:^\[0\d{2}]|\G(?!\A)).*?\R\[\K\?{3}(?=.*?\R\[0)"
Local $sString = "[000] Foo" & @CRLF & _
"[???] Foo" & @CRLF & _
"[020] Foo" & @CRLF & _
"[???] Foo" & @CRLF & _
"[045] Foo" & @CRLF & _
"[???] Foo" & @CRLF & _
"[???] Foo" & @CRLF & _
"[100] Foo" & @CRLF & _
"[???] Foo" & @CRLF & _
"[???] Foo" & @CRLF & _
"[115] Foo" & @CRLF & _
"[???] Foo"
Local $sSubst = "1??"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)