import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?sm)(?:^\\[0\\d{2}]|\\G(?!\\A)).*?\\R\\[\\K\\?{3}(?=.*?\\R\\[0)";
final String string = "[000] Foo\n"
+ "[???] Foo\n"
+ "[020] Foo\n"
+ "[???] Foo\n"
+ "[045] Foo\n"
+ "[???] Foo\n"
+ "[???] Foo\n"
+ "[100] Foo\n"
+ "[???] Foo\n"
+ "[???] Foo\n"
+ "[115] Foo\n"
+ "[???] Foo";
final String subst = "1??";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}