const regex = /(?sm)(?:^\[0\d{2}]|\G(?!\A)).*?\R\[\K\?{3}(?=.*?\R\[0)/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?sm)(?:^\\[0\\d{2}]|\\G(?!\\A)).*?\\R\\[\\K\\?{3}(?=.*?\\R\\[0)', 'g')
const str = `[000] Foo
[???] Foo
[020] Foo
[???] Foo
[045] Foo
[???] Foo
[???] Foo
[100] Foo
[???] Foo
[???] Foo
[115] Foo
[???] Foo`;
const subst = `1??`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);