re = /(?sm)(?:^\[0\d{2}]|\G(?!\A)).*?\R\[\K\?{3}(?=.*?\R\[0)/
str = '[000] Foo
[???] Foo
[020] Foo
[???] Foo
[045] Foo
[???] Foo
[???] Foo
[100] Foo
[???] Foo
[???] Foo
[115] Foo
[???] Foo'
subst = '1??'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result