import Foundation
let pattern = #"(?sm)(?:^\[0\d{2}]|\G(?!\A)).*?\R\[\K\?{3}(?=.*?\R\[0)"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
[000] Foo
[???] Foo
[020] Foo
[???] Foo
[045] Foo
[???] Foo
[???] Foo
[100] Foo
[???] Foo
[???] Foo
[115] Foo
[???] Foo
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"1??"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)