#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "((?:[a-zA-Z][0-9a-zA-Z]*)(?:\,\s*[a-zA-Z][0-9a-zA-Z]*){0,2})\s+in\s+([a-zA-Z][0-9a-zA-Z\.]*)"
Local $sString = "//초록색으로 표시되는 부분(A)에는 객체의 속성값, 키값, 인덱스값을 각각 표현할 단어를 지정합니다" & @CRLF & _
"//빨간색 부분(B)에는 바인딩 할 객체를 지정합니다. '.'을 통해 내부 객체에 접근할수도 있습니다." & @CRLF & _
"//전체적으로 A in B의 형태를 띄게 됩니다." & @CRLF & _
"" & @CRLF & _
"val, key, index in sampleObj.inner" & @CRLF & _
"val, key in sampleObj.inner" & @CRLF & _
"val in sampleObj"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")