re = /((?:[a-zA-Z][0-9a-zA-Z]*)(?:\,\s*[a-zA-Z][0-9a-zA-Z]*){0,2})\s+in\s+([a-zA-Z][0-9a-zA-Z\.]*)/
str = '//초록색으로 표시되는 부분(A)에는 객체의 속성값, 키값, 인덱스값을 각각 표현할 단어를 지정합니다
//빨간색 부분(B)에는 바인딩 할 객체를 지정합니다. \'.\'을 통해 내부 객체에 접근할수도 있습니다.
//전체적으로 A in B의 형태를 띄게 됩니다.
val, key, index in sampleObj.inner
val, key in sampleObj.inner
val in sampleObj'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end