#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(-?\d+\.?\d*E?\-?\d*)$"
Local $sString = "1.34E-200" & @CRLF & _
"12" & @CRLF & _
"1E100" & @CRLF & _
"123.45" & @CRLF & _
"Hello world" & @CRLF & _
"-12.45E-12"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")