$re = '/^(-?\d+\.?\d*E?\-?\d*)$/m';
$str = '1.34E-200
12
1E100
123.45
Hello world
-12.45E-12';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);