use strict;
my $str = 'ID Flag
P-MTP00197854/03 X
P-MTP00197868/02 X
P-MTP00197882/00 X
P-HMF00197730
WI/B09/077094
Q-MTP00197735
Q-HMF00199313/0 X
Q-HMF/23/00199313/0 X';
my $regex = qr/\/\d{1,2}\b(?=[^\r\n\/]*$)/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}