package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?mi)([\d]*?)([dD][\d]*)(([\+\-\*])[\d]*|([\+\-\*])\(([a-zA-Z]*)\))?`)
var str = `1D10*10
D10+20
D10+D10
D10+(Strength)
D10+20+1*2+(Strength)+D10`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}