using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(\+\d+)";
string input = @"BEGIN:VCARD
VERSION:3.0
TEL;TYPE=VOICE,CELL;VALUE=text:+79068006291
END:VCARD
BEGIN:VCARD
VERSION:3.0
TEL;TYPE=VOICE,CELL;VALUE=text:+79961763119
END:VCARD
BEGIN:VCARD
VERSION:3.0
TEL;TYPE=VOICE,CELL;VALUE=text:+79028796733
END:VCARD
BEGIN:VCARD
VERSION:3.0
TEL;TYPE=VOICE,CELL;VALUE=text:+79630332596
END:VCARD
BEGIN:VCARD
VERSION:3.0
TEL;TYPE=VOICE,CELL;VALUE=text:+79068024291
END:VCARD
BEGIN:VCARD
VERSION:3.0
TEL;TYPE=VOICE,CELL;VALUE=text:+79521360575
END:VCARD
BEGIN:VCARD
VERSION:3.0";
RegexOptions options = RegexOptions.Singleline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}