# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/\d([0-9]{6})([0-9]{0,16})([0-9]{4})\d/$1******$3/g;t' <<< "Aaaa bbbb aaa=1234567890123456 fdfdfd=aaa
Aaaa bbbb aaa=\\"1234567890123456\\" fdfdfd=aaa
Aaaa bbbb aaa=5155900762048745 fdfdfd=aaa"