#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "\d([0-9]{6})([0-9]{0,16})([0-9]{4})\d"
Local $sString = "Aaaa bbbb aaa=1234567890123456 fdfdfd=aaa" & @CRLF & _
"Aaaa bbbb aaa=\"1234567890123456\" fdfdfd=aaa" & @CRLF & _
"Aaaa bbbb aaa=5155900762048745 fdfdfd=aaa"
Local $sSubst = "$1******$3"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)