import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\d([0-9]{6})([0-9]{0,16})([0-9]{4})\\d";
final String string = "Aaaa bbbb aaa=1234567890123456 fdfdfd=aaa\n"
+ "Aaaa bbbb aaa=\\\"1234567890123456\\\" fdfdfd=aaa\n"
+ "Aaaa bbbb aaa=5155900762048745 fdfdfd=aaa";
final String subst = "$1******$3";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}