Please enable JavaScript to use regex101
/
^
r
e
g
e
x
[
\
-
_
]
?
1
0
1
$
/
i
Reg
ular
Ex
pressions
101
Upgrade to Pro
Enterprise
Regular Expression
/
\d([0-9]{6})([0-9]{0,16})([0-9]{4})\d
/
g
Input 1
1
New
Aaaa bbbb aaa=1234567890123456 fdfdfd=aaa Aaaa bbbb aaa=\"1234567890123456\" fdfdfd=aaa Aaaa bbbb aaa=5155900762048745 fdfdfd=aaa
Substitution
$1******$3
Aaaa bbbb aaa=1234567890123456 fdfdfd=aaa Aaaa bbbb aaa=\"1234567890123456\" fdfdfd=aaa Aaaa bbbb aaa=5155900762048745 fdfdfd=aaa