const regex = /(?<!\\)(?:\\{2})*(?:"[^\\"]*(?:\\.[^"\\]*)*"|'[^\\']*(?:\\.[^'\\]*)*')(*SKIP)(*F)|\h+/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<!\\\\)(?:\\\\{2})*(?:"[^\\\\"]*(?:\\\\.[^"\\\\]*)*"|\'[^\\\\\']*(?:\\\\.[^\'\\\\]*)*\')(*SKIP)(*F)|\\h+', 'gm')
const str = `2 + 2
2+2
f( " ")
f(" ")
f("Test \\"mystring\\" .")
f("Test \\"mystring\\" .")
f("' ", " ")
f("' "," ")`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);