#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m).+([chds]).+\1.+\1.+\1.+\1"
Local $sString = "10hJh7hAh2h" & @CRLF & _
"10cJcQcKcAc" & @CRLF & _
"10cJcQcKhAh // No Match" & @CRLF & _
"2d3d4d5d6d"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")