package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`%(\w)`)
var str = `%252525253E%252553Csvg%25252525252525252Fonload%252525252525252525252525252525252525252525252525252525253Dalert(document.domain)%252525252`
var substitution = "\1"
fmt.Println(re.ReplaceAllString(str, substitution))
}