#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)(?<fullMatch>(?<prop>\w+\s*=\s*)({)(?<quote1>["'`])(?<string>[^"$'`{}]*)(?<quote2>["'`])(}))"
Local $sString = "<ReactComponent" & @CRLF & _
" property={true}" & @CRLF & _
" target={'string'}" & @CRLF & _
"/>" & @CRLF & _
"" & @CRLF & _
"export const ReactComponent = () => <div property target={"string"} />" & @CRLF & _
"" & @CRLF & _
"<ReactComponent" & @CRLF & _
" property={true}" & @CRLF & _
" target={`string`}" & @CRLF & _
"/>"
Local $sSubst = "$2$4$5$6"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)