#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "https?:\/\/([a-z0-9]+\.)+(at|de|ch)(\/[a-z]+)*\/?(\?[a-z]+=[a-z]*(&[a-z]+=[a-z]*)*)?"
Local $sString = "http://a1.at" & @CRLF & _
"http://orf.at/" & @CRLF & _
"https://tc.tugraz.at/main" & @CRLF & _
"http://www.derstandard.at/kultur/" & @CRLF & _
"https://wikipedia.at/wiki/regex/" & @CRLF & _
"http://duckduckgo.at/?q=regex" & @CRLF & _
"https://gdi.ist.tugraz.at?user=student" & @CRLF & _
"http://gdi.ist.tugraz.at/login?course=gdi&role=student" & @CRLF & _
"http://tugraz.at?emptyparam=" & @CRLF & _
"" & @CRLF & _
"ε (Leerstring)" & @CRLF & _
"http" & @CRLF & _
"http://" & @CRLF & _
"http://www" & @CRLF & _
"http://.at" & @CRLF & _
"http://orf.at//" & @CRLF & _
"https://de.wikipedia.org" & @CRLF & _
"http://tugraz.at/?" & @CRLF & _
"http://gdi.ist.tugraz.at/?user=student&" & @CRLF & _
"http://?user=student" & @CRLF & _
"https://tugraz.at?user"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")