import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "https?:\\/\\/([a-z0-9]+\\.)+(at|de|ch)(\\/[a-z]+)*\\/?(\\?[a-z]+=[a-z]*(&[a-z]+=[a-z]*)*)?";
final String string = "http://a1.at\n"
+ "http://orf.at/\n"
+ "https://tc.tugraz.at/main\n"
+ "http://www.derstandard.at/kultur/\n"
+ "https://wikipedia.at/wiki/regex/\n"
+ "http://duckduckgo.at/?q=regex\n"
+ "https://gdi.ist.tugraz.at?user=student\n"
+ "http://gdi.ist.tugraz.at/login?course=gdi&role=student\n"
+ "http://tugraz.at?emptyparam=\n\n"
+ "ε (Leerstring)\n"
+ "http\n"
+ "http://\n"
+ "http://www\n"
+ "http://.at\n"
+ "http://orf.at//\n"
+ "https://de.wikipedia.org\n"
+ "http://tugraz.at/?\n"
+ "http://gdi.ist.tugraz.at/?user=student&\n"
+ "http://?user=student\n"
+ "https://tugraz.at?user";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}