use strict;
my $str = 'http://a1.at
http://orf.at/
https://tc.tugraz.at/main
http://www.derstandard.at/kultur/
https://wikipedia.at/wiki/regex/
http://duckduckgo.at/?q=regex
https://gdi.ist.tugraz.at?user=student
http://gdi.ist.tugraz.at/login?course=gdi&role=student
http://tugraz.at?emptyparam=
ε (Leerstring)
http
http://
http://www
http://.at
http://orf.at//
https://de.wikipedia.org
http://tugraz.at/?
http://gdi.ist.tugraz.at/?user=student&
http://?user=student
https://tugraz.at?user';
my $regex = qr/https?:\/\/([a-z0-9]+\.)+(at|de|ch)(\/[a-z]+)*\/?(\?[a-z]+=[a-z]*(&[a-z]+=[a-z]*)*)?/p;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}