# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^\/([a-zA-Z]{2}-[a-zA-Z]{2})\/cms\/api\/preview([a-zA-Z0-9-_=\/]*)(\?)(.*)"
test_str = ("/en-US/cms/api/preview/pippo/paperino/pluto/minni/amelia#user=Artibani?qui=qua&quo=qui\n"
"/en-US/cms/api/preview/pippo/paperino/pluto/minni/amelia#/user=Artibani?qui=qua&quo=qui\n"
"/en-US/cms/api/preview/pippo/paperino/pluto/DePaperoni=ricco/amelia/#user/Artibani?qui=qua&quo=qui\n"
"/en-US/cms/api/preview/pippo/paperino/pluto/DePaperoni=ricco/amelia/#/user=Artibani?qui=qua&quo=qui\n"
"/en-US/cms/api/preview/pippo/pluto23?qua=qui\n"
"/en-US/cms/api/preview/pippo-clarabella/EN-us/123???\n"
"/en-US/cms/api/preview/pippo/pluto-orazio?\n"
"/en-US/cms/api/preview/pippo/pico-archimede/\n"
"/en-US/cms/api/preview/pippo/pico/archimede\n"
"/en-US/cms/api/preview/pippo/paperino/pluto/minni/amelia#user/Faraci\n"
"/en-US/cms/api/preview/pippo/paperino/pluto/minni/amelia/#user=Faraci\n"
"/en-US/cms/api/preview\n"
"/en-US/cms/api/preview/\n"
"/en-US/cms/api/preview?\n"
"/en-US/cms/api/preview/?\n"
"/en-US/cms/api/preview#user=Artibani?qui=qua&quo=qui&cap_paperopoli=123\n"
"/en-US/cms/api/preview/#user/Artibani?qui=qua&quo=qui&cap_paperopoli=123\n"
"/en-US/cms/api/preview#/user=Artibani?qui=qua&quo=qui&cap_paperopoli=123\n"
"/en-US/cms/api/preview/#/user=Artibani?qui=qua&quo=qui&cap_paperopoli=123\n"
"/en-US/cms/api/preview#user=Faraci\n"
"/en-US/cms/api/preview#/user=Faraci\n"
"/en-US/cms/api/preview/#/user=Faraci\n"
"/en-US/cms/api/preview/pippo/paperino/pluto/minni/amelia?qui=qua&quo=qui\n"
"/en-US/cms/api/preview/pippo/paperino/pluto/DePaperoni=ricco/paperoga?qui=qua&quo=qui\n"
"/en-US/cms/api/preview/pippo/pluto23?qua=qui\n"
"/en-US/cms/api/preview/pippo-clarabella/EN-us/123???\n"
"/en-US/cms/api/preview/pippo/pluto-orazio?\n"
"/en-US/cms/api/preview/pippo/pico-archimede/?\n"
"/en-US/cms/api/preview/pippo/pico-archimede/\n"
"/en-US/cms/api/preview/pippo/pico/archimede\n"
"/en-US/cms/api/preview/pippo/paperino/pluto/minni/amelia#user=Faraci\n"
"/en-US/cms/api/preview/pippo/paperino/pluto/minni/amelia/#user/Faraci\n"
"/en-US/cms/api/preview/pippo/paperino/pluto/minni/amelia/#/user=Faraci\n"
"/en-US/cms/api/preview\n"
"/en-US/cms/api/preview/\n"
"/en-US/cms/api/preview?\n"
"/en-US/cms/api/preview/?\n"
"/en-US/cms/api/preview#user=Faraci\n"
"/en-US/cms/api/preview/#user/6Faraci\n\n"
"NOT OK\n"
"/en-US/cms/api/preview?#user=Faraci\n"
"/en-US/cms/api/preview?#/user=Faraci\n"
"/en-US/cms/api/preview?/#/user=Faraci\n"
"/en-US/cms/api/preview/?#user=Faraci\n"
"/en-US/cms/api/preview/?#/user/Faraci\n"
"/en-US/cms/api/preview/?/#/user=Faraci\n"
"/en-US/cms/api/preview/pippo/paperino/pluto/minni/amelia?qui=qua&quo=qui#userArtibani\n"
"/en-US/cms/api/preview/pippo/paperino/pluto/minni/amelia/?qui=qua&quo=qui#user/Artibani\n"
"/en-US/cms/api/preview?qui=qua&quo=qui#user/Artibani\n"
"/en-US/cms/api/preview/?qui=qua&quo=qui#user=Artibani\n"
"/en-US/cms/api/preview?#user=Faraci\n"
"/en-US/cms/api/preview/?#user/Faraci\n\n\n\n"
"Output for Nginx:\n"
"/preview/$2?culture=$1&$4")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.