#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?:https?:\/\/)?(?:www\.)?(?:youtube\.com\/watch\?v=([a-zA-Z0-9_]+)|youtu\.be\/([a-zA-Z\d_]+))(?:&.*)?$"
Local $sString = "http://www.youtube.com/watch?v=p72I7gRXpg" & @CRLF & _
"http://youtube.com/watch?v=bQVoAWSP7k4" & @CRLF & _
"http://www.youtube.com/watch?v=bQVoAWSP7k4" & @CRLF & _
"https://youtu.be/6WZoMAVCggM" & @CRLF & _
"http://www.youtube.com/watch?v=6WZoMAVCggM&" & @CRLF & _
"http://www.youtube.com/watch?v=bQVoAWSP7k4&feature=popular" & @CRLF & _
"http://www.youtube.com/watch?v=McNqjYiFmyQ&feature=related&bhablah" & @CRLF & _
"www.youtube.com/watch?v=McNqjYiFmyQ&feature=related&bhablah" & @CRLF & _
"youtu.be/6WZoMAVCggM" & @CRLF & _
"youtube.com/watch?v=bQVoAWSP7k4" & @CRLF & _
"http://youtube.com/watch?v=bQVoAWSP7k4" & @CRLF & _
"http://youtu.be/6WZoMAVCg"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")