import re
regex = re.compile(r"^localhost:8080(?!\/api)(?:\/\w+)*$", flags=re.MULTILINE)
test_str = ("localhost:8080\n"
"localhost:8080/settings\n"
"localhost:8080/settings/users\n"
"localhost:8080/settings/users/roles\n"
"localhost:8080/settings/users/roles/admin\n\n"
"localhost:8080/style.css\n"
"localhost:8080/manifest.json\n"
"localhost:8080/api\n"
"localhost:8080/api/users\n"
"localhost:8080/api/users/abc")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")