$re = '/\/\*[\s\S]*?\*\/|([^\\\\:]|^)\/\/.*$/m';
$str = '// fallback response. For more information contact support
channels=[\'channel1\',\'channel2\'];
/* i am some very long
long long long comment */
channels=[\'channel1\',\'channel2\'];
// comment 1
//comment 2
channels=[\'channel1\',\'channel2\'];';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);