re = /(?<!\S)\d+\.\s((?:\d+\.\s)*[^\s.,:!?]+)/m
str = '1. text
2. wordX wordY.
3. 4. wordZ.'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end