package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(R)[^|]+(\|)`)
var str = `RDA
3|4|`
var substitution = "$1$2"
fmt.Println(re.ReplaceAllString(str, substitution))
}