#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^http(?:s)?:\/\/(?:[\w-]+\.?)+\/[\w-\.]+(\/[\w-])?$"
Local $sString = "http://my.de/site" & @CRLF & _
"https://another" & @CRLF & _
"https://another.site" & @CRLF & _
"https://another.site.de/site" & @CRLF & _
"https://another.site-s.de/site" & @CRLF & _
"https://another.site/de" & @CRLF & _
"http://foodfacts.mercola.com/green-tea.html" & @CRLF & _
"http://foodfacts.mercola.com/green-tea.html/ssja" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")