package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^http(?:s)?:\/\/(?:[\w-]+\.?)+\/[\w-\.]+(\/[\w-])?$`)
var str = `http://my.de/site
https://another
https://another.site
https://another.site.de/site
https://another.site-s.de/site
https://another.site/de
http://foodfacts.mercola.com/green-tea.html
http://foodfacts.mercola.com/green-tea.html/ssja
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}