re = /^http(?:s)?:\/\/(?:[\w-]+\.?)+\/[\w-\.]+(\/[\w-])?$/m
str = 'http://my.de/site
https://another
https://another.site
https://another.site.de/site
https://another.site-s.de/site
https://another.site/de
http://foodfacts.mercola.com/green-tea.html
http://foodfacts.mercola.com/green-tea.html/ssja
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end