re = /(.*?)(\[(@.+?)\])(((?!(\[@.+?\])).)*)/m
str = 'Hello [@foo] how are you [@bar] more text'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end