const regex = /^\w{3,16}$/gmi;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^\\w{3,16}$', 'gmi')
const str = `awesome
1232443242
34
45453.54
1
2
3342
43543
.co
coo
niceee
minecraftGamer23
co
_nicelol23__
T_T
1.2e3
awo!d
awesome`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}