# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/({{TICKETS}}.*?{{\\/TICKETS}})/<div class="ticket">x<\/div>/misg;t' <<< "<body>
{{TICKETS}}
<div class=\"ticket\">{{asd}}</div>
{{/TICKETS}}
{{TICKETS}}
</body>"