// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?mis)({{TICKETS}}.*?{{\/TICKETS}})").unwrap();
let string = "<body>
{{TICKETS}}
<div class=\"ticket\">{{asd}}</div>
{{/TICKETS}}
{{TICKETS}}
</body>";
let substitution = "<div class=\"ticket\">x</div>";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}