# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/\s+(https?.+?)(<|\s)/ <a href="$1">$1<\/a>$2/gm;t' <<< "<h1>Hello</h1>
Visit this link: http://www.link1.com<br />
Visit this link: http://www.link1.com <br />
Visit this link: http://www.link1.com/some_other_words <br />
And <strong>this</strong>:
<a href=\"http://www.link2.com\">http://www.link2.com</a>"