#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)\s+(https?.+?)(<|\s)"
Local $sString = "<h1>Hello</h1>" & @CRLF & _
"Visit this link: http://www.link1.com<br />" & @CRLF & _
"Visit this link: http://www.link1.com <br />" & @CRLF & _
"Visit this link: http://www.link1.com/some_other_words <br />" & @CRLF & _
"And <strong>this</strong>: " & @CRLF & _
"<a href="http://www.link2.com">http://www.link2.com</a>"
Local $sSubst = " <a href="$1">$1</a>$2"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)