import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\s+(https?.+?)(<|\\s)";
final String string = "<h1>Hello</h1>\n"
+ "Visit this link: http://www.link1.com<br />\n"
+ "Visit this link: http://www.link1.com <br />\n"
+ "Visit this link: http://www.link1.com/some_other_words <br />\n"
+ "And <strong>this</strong>: \n"
+ "<a href=\"http://www.link2.com\">http://www.link2.com</a>";
final String subst = " <a href=\"$1\">$1</a>$2";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}