use strict;
my $str = 'https://www.fanball.com/
https://www.fanball.com/lobby
https://www.fanball.com/lobby/
https://www.fanball.com/lobby/blah
https://www.fanball.com/lobby/?foo=bar
https://staging.fanball.com/
https://staging.fanball.com/lobby
https://staging.fanball.com/lobby/
https://staging.fanball.com/lobby/blah
https://staging.fanball.com/lobby/?foo=bar
https://fanball-qa.shub.dog/
https://fanball-qa.shub.dog/lobby
https://fanball-qa.shub.dog/lobby/
https://fanball-qa.shub.dog/lobby/blah
https://fanball-qa.shub.dog/lobby/?foo=bar';
my $regex = qr/^https:\/\/(((www|staging)\.fanball\.com\/lobby\/?(\?.*)?$)|fanball-qa\.shub\.dog\/lobby\/?(\?.*)?$)/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}