package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)<input type="hidden" name="csrftoken" value="(?P<token>.+?)"`)
var str = `<input type="hidden" name="csrftoken" value="somerandomtokenvalue">`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}